Jump to content


Photo

not honoring private {..} in Sources

private source citation

  • Please log in to reply
5 replies to this topic

#1 stanje1

stanje1

    New Member

  • Members
  • Pip
  • 4 posts

Posted 19 February 2015 - 09:15 PM

I am newbie, converting from TMG.  I see a bug(?) that was reported here in 2010-2012 forums and still seems to be a problem?  Maybe I am missing a fix?    I have private info in sources and source citations, like {email address} or {street address} in the source and / or citation.  Any reports I do, even tho I specify hide private data everywhere, private data is not honored and still shows the {xxx} data, as is.   For example, it occurs in Family Group Report, even with Sources-Options-Hide Private Data in Endnotes, Footnotes, Bibliography checked.  It also occurs Reports-Lists-Source List.   What am I missing ?  Works fine in a Person Note and probably other notes.



#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Admin
  • PipPipPip
  • 8779 posts

Posted 20 February 2015 - 11:50 AM

You can privatize fields in the custom source templates. Look at the Email Message source template for an example. You will want to make a copy of the source template if you want to privatize fields that are not already done so. The ! for privatizing goes in the footnote template.


Renee
RootsMagic

#3 stanje1

stanje1

    New Member

  • Members
  • Pip
  • 4 posts

Posted 21 February 2015 - 09:46 AM

Not really acceptable.  That means I have to modify all the many, many source templates I use and modify all my original sources to put the private stuff in defined fields, rather than in-line words with {xxx}.   Also... isn't this still is a bug, why have the {xxx} option... and if you go to Reports--Family Group Sheet (for example)-- then click "Sources" button, then Options tab... shows an option for "Hide private data in the endnotes, footnotes, bibliography"... what good is that ? Is the problem that I am probably using old, imported "TMG_" source templates rather than RM templates?  (sorry, but a new user and struggling with learning new software and wanting not to lose what I have !)



#4 stanje1

stanje1

    New Member

  • Members
  • Pip
  • 4 posts

Posted 21 February 2015 - 10:44 AM

okay...  the problem may be that all my sources are imported and are all using the "_TMG_" templates. I see the differences in the _TMG_E-Mail Message template and the RM E-Mail message template.  Now... is there any way to edit existing source(s) and change the source type from the _TMG_ type to the RM type?   (I also have same problem with {xx} private data in some of my repositories and see no way around that...no option to exclude private data in the repository reports, but less of an issue, tho)   Thanks !



#5 stanje1

stanje1

    New Member

  • Members
  • Pip
  • 4 posts

Posted 21 February 2015 - 12:35 PM

My last entry...  I am learning !  

My main problem.. TMG consistently used {xxxx} anywhere you wanted to optionally show/no show stuff.  This included note text, sources, citations, preparer info, repositories.   RM apparently does not handle all instances of "private" data the same and implements privacy in many different ways !  

My testing:

1.  {xxxx} - *only* works on text embedded in notes.  Not recognized elsewhere...  source, citation, preparer info, repositories

2.  You can check "private" on a whole fact or note most anywhere

3.  Sources/Citations- you must use the correct template with *certain* fields coded with the " ! " notation.  Then, only those whole fields are hidden or not...  the {xxxx} notation is ignored.

4.  Repositories and Preparer info... no support

So.. a lot of work changing templates and/or re-editing my sources, and still not all functions supported (repositories, preparer info)

 

Thanks for "listening"  :)



#6 KC1SP

KC1SP

    Member

  • Members
  • PipPip
  • 5 posts

Posted 13 February 2017 - 02:10 PM

I am also a new user, transplanted from TMG.  The below precisely describes my problem, in that it does NOT ignore {xxxx} data in citations (specifically the Detail Text and Comments boxes of citations).  My question is:  Has this been fixed?  I once generated a GEDCOM from my family tree to give to a person who asked for specific data, and I included sources.  Luckily I checked the GEDCOM before emailing, and discovered TO MY HORROR that there was personal information in the source attached to one of the dead folks (included in {xxx} correctly).  I manually edited the GEDCOM to remove that data.  But now I question the security of this in general, since you get either the option to include sources, or NOT include sources.  Is the answer is that Roots Magic simply does not support private data everywhere, especially in sources, unless it's specifically embedded in the template itself?

 

Thank you for any enlightenment to a new user of Roots Magic....and now you understand why some of us TMG users are reluctant to switch over.... Thanks much for any assistance.

 

My last entry...  I am learning !  

My main problem.. TMG consistently used {xxxx} anywhere you wanted to optionally show/no show stuff.  This included note text, sources, citations, preparer info, repositories.   RM apparently does not handle all instances of "private" data the same and implements privacy in many different ways !  

My testing:

1.  {xxxx} - *only* works on text embedded in notes.  Not recognized elsewhere...  source, citation, preparer info, repositories

2.  You can check "private" on a whole fact or note most anywhere

3.  Sources/Citations- you must use the correct template with *certain* fields coded with the " ! " notation.  Then, only those whole fields are hidden or not...  the {xxxx} notation is ignored.

4.  Repositories and Preparer info... no support

So.. a lot of work changing templates and/or re-editing my sources, and still not all functions supported (repositories, preparer info)

 

Thanks for "listening"   :)







Also tagged with one or more of these keywords: private, source, citation