Jump to content


Photo

Mapping not working


  • Please log in to reply
24 replies to this topic

#1 lmsalgado

lmsalgado

    Member

  • Members
  • PipPip
  • 12 posts

Posted 19 February 2015 - 10:35 AM

I have been suffering with some minor issues with RM7, most of them corrected with the update.

But now suddenly the Mapping Tool stopped working.  It never worked very well for people but now wherever I choose, it just shows the map with a pin in the corner of the map and zooms to South Dakota, US  (my data is almost all in Portugal many time zones away :D)

Have someone else experimented this problem?

 

 



#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7993 posts

Posted 19 February 2015 - 12:28 PM

Have you installed the Place Database and geocoded your places?  You can download the Place Database Installer here - http://rootsmagic.co...d/Rootsmagic-7/

 

Also make sure RootsMagic 7 has access to the internet. That your firewall and anti-virus program are not blocking it. 


Renee
RootsMagic

#3 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3207 posts

Posted 19 February 2015 - 12:30 PM

I don't use RM7 but I can't see why Mapping would be broken except it did get the inclusion of Place Details in the last update.

 

I am assuming all your places are geocoded? and I am also assuming when you arrow down through your People or Place sidebar Mapping never changes from South Dakota?

 

Please confirm.


Overcome the negatives, then only positives and praise remains.....

 

 

Current user of Rootsmagic version 7.5.7.0, Family Tree Maker 2014 and Legacy 7.5 on Win 10

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#4 lmsalgado

lmsalgado

    Member

  • Members
  • PipPip
  • 12 posts

Posted 20 February 2015 - 05:50 AM

Thanks for your suggestions.

I had the Place Database installed but, just to be sure, I just downloaded and installed it again. Still no luck.

I have internet access. I can even navigate in the map manually.

I think the North Dakota it is just a random place, if i change the map manually and click in some of my places the map zooms to somewhere near where I left it.

 

The places are almost all geocode except for a dozen. And I just noticed the stranger thing: clicking in some of these non-geocoded places brings me to the correct location on the map  :P   Maybe I should delete the geolocation on all the other places eheh.



#5 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3207 posts

Posted 20 February 2015 - 11:21 AM

Thanks for your suggestions.

I had the Place Database installed but, just to be sure, I just downloaded and installed it again. Still no luck.

I have internet access. I can even navigate in the map manually.

I think the North Dakota it is just a random place, if i change the map manually and click in some of my places the map zooms to somewhere near where I left it.

 

The places are almost all geocode except for a dozen. And I just noticed the stranger thing: clicking in some of these non-geocoded places brings me to the correct location on the map  :P   Maybe I should delete the geolocation on all the other places eheh.

 

You mentioned Portugal before (my home from home) but didn't mention where you were?

 

This reminds me of a previous discussion which I just can't find at present where some Windows program settings were wrong giving Rootsmagic a problem with geocoding. Maybe this is the problem you are having and maybe Renee can jump in later with a reminder of that issue.


Overcome the negatives, then only positives and praise remains.....

 

 

Current user of Rootsmagic version 7.5.7.0, Family Tree Maker 2014 and Legacy 7.5 on Win 10

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#6 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7993 posts

Posted 20 February 2015 - 12:08 PM

I think Windows was using a comma instead of a period in the geocoding on some versions of Windows.


Renee
RootsMagic

#7 lmsalgado

lmsalgado

    Member

  • Members
  • PipPip
  • 12 posts

Posted 23 February 2015 - 07:09 AM

 

You mentioned Portugal before (my home from home) but didn't mention where you were?

 

Most of my records are around Guimaraes and Oporto (including my own record). Glad to know you fell at home here :)

 

 

 

You mentioned Portugal before (my home from home) but didn't mention where you were?

 

This reminds me of a previous discussion which I just can't find at present where some Windows program settings were wrong giving Rootsmagic a problem with geocoding. Maybe this is the problem you are having and maybe Renee can jump in later with a reminder of that issue.

 

After doing some tests, I found that you're right!

If I change my Windows's regional settings to have a dot (.) as a decimal separator and a coma (,) as a digit grouping  (like 123,456,789.00) then it all works well.

 

But (Attention RootsMagic developers) these is NOT wrong windows setting: in Portugal, just as in half of the world (most Europe, north Asia, South America and Western Africa), we use a coma (,) as a decimal separator  (the same example before shows like this 123.456.789,00)

Also Bings Maps accept both systems.

 

 

So this ends up beeing a Roots Magic issue and I hope it gets noted and corrected by it's great team. Thanks ;)



#8 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7993 posts

Posted 23 February 2015 - 11:42 AM

Confirming issue is noted in tracking system. 


Renee
RootsMagic

#9 lmsalgado

lmsalgado

    Member

  • Members
  • PipPip
  • 12 posts

Posted 23 February 2015 - 12:33 PM

Confirming issue is noted in tracking system. 

 

Thanks! You are truly a great team!!!



#10 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3207 posts

Posted 23 February 2015 - 02:22 PM

 

So this ends up beeing a Roots Magic issue and I hope it gets noted and corrected by it's great team. Thanks ;)

 

Thanks for the comments, Portuguese Algarve tomorrow morning for some R&R, and also good to see Rootsmagic accepting this as an issue to be resolved as it has come up before.


Overcome the negatives, then only positives and praise remains.....

 

 

Current user of Rootsmagic version 7.5.7.0, Family Tree Maker 2014 and Legacy 7.5 on Win 10

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#11 austrian_genealogy

austrian_genealogy

    Member

  • Members
  • PipPip
  • 28 posts

Posted 24 February 2015 - 04:21 AM

Confirming issue is noted in tracking system. 

 

Renee, I hope you don't have this issue twice in your tracking system. I reported this issue exactly one year ago:

24 February 2014: http://forums.rootsm...set-to-english/

 

Kind regards

Reinhard



#12 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7993 posts

Posted 24 February 2015 - 10:52 AM

Normally issues are only in the tracking system once. Then we add addition reports and comments to them. 


Renee
RootsMagic

#13 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3207 posts

Posted 24 February 2015 - 12:04 PM

Normally issues are only in the tracking system once. Then we add addition reports and comments to them. 

 

I do have to repeat myself that in my opinion these known ISSUES do really need to be resolved within the life of the version they were reported in and not run on version after version.

 

Otherwise those users who paid for that version are being well and truly short changed which is not good customer service. <_<


Overcome the negatives, then only positives and praise remains.....

 

 

Current user of Rootsmagic version 7.5.7.0, Family Tree Maker 2014 and Legacy 7.5 on Win 10

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#14 lmsalgado

lmsalgado

    Member

  • Members
  • PipPip
  • 12 posts

Posted 24 February 2015 - 01:20 PM

 

I reported this issue exactly one year ago

 

One year ago?! That's not so great. I guess I can't expect to use this feature anytime soon. :(

 

 

I do have to repeat myself that in my opinion these known ISSUES do really need to be resolved within the life of the version they were reported in and not run on version after version.

 

I must agree with Vyger. I guess I'm not the only non US/UK paying user, many others must be unable to use this nice feature.



#15 austrian_genealogy

austrian_genealogy

    Member

  • Members
  • PipPip
  • 28 posts

Posted 10 April 2015 - 01:08 AM

Additional comment:

 

This issue has already been added to the tracking system by Renee in 2011:

http://forums.rootsm...-place-details/



#16 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3207 posts

Posted 10 April 2015 - 02:57 AM

This issue has already been added to the tracking system by Renee in 2011:

http://forums.rootsm...-place-details/

 

It will probably be ready Thursday <_<

 

Rootsmagic strives to have worldwide appeal so this known compatibility issue going back to 2008 should get some priority, it has already wasted a lot of time for several non US/UK users.

 

http://blog.rootsmagic.com/?p=65


Overcome the negatives, then only positives and praise remains.....

 

 

Current user of Rootsmagic version 7.5.7.0, Family Tree Maker 2014 and Legacy 7.5 on Win 10

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#17 Jasper2

Jasper2

    Member

  • Members
  • PipPip
  • 7 posts

Posted 19 July 2018 - 08:50 AM

In 2018, same problem with geocoding .

 1/ When I edit geocode on details, coordinates are displayed in some case (see below) but when I say OK coordinates are not saved (in France).

2/ Could somebody explain to me how to enter  48° 50' 45.94" N ?

For me

Enter                     Display                             Result after OK (saving?)

48 50 45 works,  >40° 50' 45,00" N                  Blank

48 50 45,94        >0° 0' 0,00" N                        Blank

48 50 45,94       > 0° 0' 0,00" N                        Blank

3/It could be useful to complete documentation on how to enter geocode (no explanation now).

4/ When you edit any geocoded place ( known by the gazeeter), and you want to save it (OK) coordinates will be desappear !

 

I will be happy to know why this incident reported many time is not resolved on 2018 and I expect that it will be corrected sooner in a patch



#18 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7993 posts

Posted 19 July 2018 - 11:11 AM

I think the problem is the commas instead of a period. 


Renee
RootsMagic

#19 lmsalgado

lmsalgado

    Member

  • Members
  • PipPip
  • 12 posts

Posted 19 July 2018 - 11:40 AM

3 years ago I praised RootsMagic's team for being so quick to add this problem to the tracking system, I didn’t know at the time that it was there since 2011… well, turns out that 7 years weren’t enough to address the problem yet.

RootsMagic is a very good application, but a lot of little problems like this were never addressed and I guess never will. I am seriously tempted to drop it for any other application.

 

Anyway, a workaround to the problem is to temporarily change your system (Windows/Mac) to a different Region/Locale like USA/UK and use english as your language. Then apply the coordinates, see the maps, etc… and, after ending, restore to your region. It is very annoying but was the only solution I have found.



#20 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3207 posts

Posted 19 July 2018 - 11:52 AM

I think the problem is the commas instead of a period. 

 

There can be a problem with commas instead of periods and I believe the Windows number format can be changed after updates. For example, I have had a couple of recent updates and I notice when I copy from Bing Maps I now get the format;

 

54,874516, -6,032180

 

The comma after 54 and -6 has reappeared in Bing number formats and needs to be changed to a period for Rootsmagic to understand the co-ordinates.

 

Now, in criticism of Rootsmagic on two levels there is a real need for a very simple validation and parsing routine here which will overcome these difficulties, I will explain. When I look at the latitude and longitude in bold above I can see the two commas need to be replaced for periods, Renee has stated similar, I can also visually discern which bit is latitude and which bit is longitude, so why can't Rootsmagic?

 

Pasting such a string into the latitude field should invoke a validation and parsing routine to make this process a simple single paste operation and other programs do it. Pasting this complete string into both latutide and longitude fields in turn, manually changing commas to periods and manually deleting the unwanted portion in each field on every geocode operation is simply NOT acceptable in my opinion and such a validation and parsing routine is very easy to programme.

 

This snags me constantly in Rootsmagic and always has done for the last NINE years, if the scheme of MINOR FIXES I'm saddened to have to be so blunt as to say this tweak is well overdue and continues to cause long suffering users inconvenience and confusion.


Overcome the negatives, then only positives and praise remains.....

 

 

Current user of Rootsmagic version 7.5.7.0, Family Tree Maker 2014 and Legacy 7.5 on Win 10

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root