Jump to content


Photo

Home person in a GEDCOM file


  • Please log in to reply
29 replies to this topic

#1 Patrick R

Patrick R

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 03 January 2015 - 12:15 PM

Every time I export a GEDCOM file, it sets the person with record number "1" as the home person.  When I upload the file to Ancestry or MyHeritage, that person is always the home person.  When the file is imported by another person, the same issue exists.  SInce the first person who was entered in the file (some 20+ years ago) was a brother of my great-grandfather, it is an annoying problem every time I have to do this.

 

I'm just getting tired of having to fix it after the upload, and there have been a few times when doing so was impractical or downright impossible. 

 

Is there a way to make the Gedcom file to set a different home record for purposes of export?



#2 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 03 January 2015 - 01:05 PM

Sure. The key here is be sure to uncheck the "Preserve record numbers..." option which I can't remember whether is a prompt only in the GEDCOM import or also in dragN'drop. DragN'Dropping the person (and their family or an accompanying tree/subtree) that you want to specifically be the home person to fresh newly-created RootsMagic database is the easiest, then save/backup the database and confirm the new home person works as you desire. When it acts as you'd like, then do an additional dragN'drop of everyone in that original database to the newly-populated one and follow that with an Automatic merge. I think that'll work.

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#3 Patrick R

Patrick R

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 03 January 2015 - 01:14 PM

What "option"?  I tried the drag and drop and the only option it offered what whom I wanted to copy to the other database, but the box for "options" remained closed and unavailable.



#4 Patrick R

Patrick R

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 03 January 2015 - 01:30 PM

The only place I can find the "preserve record numbers" option is when importing GEDCOM, and it doesn't seem to work.  No matter what is checked, it always makes the same person the Root record.

 

Drag and Drop does not offer any such option, or at least the option is not intuitively displayed.

 

I noticed you boldfaced parts of your message after I left my first reply.  It's not that I couldn't understand your explanation; it's that it doesn't work for me in RMG7.



#5 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 03 January 2015 - 01:37 PM

You're making this harder than it has to be. Forget what I said about preserving record numbers ;-) If the GEDCOM to be imported only contains the person and associated family that you want to be the first (lowest) record numbers ...then a newly created database is going to have that person as Record number 1 ...PERIOD. Same with dragN'drop...PERIOD. Then importing the rest and automerge cannot possibly have record numbers lower than the first individuals added to a new database.

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#6 Patrick R

Patrick R

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 03 January 2015 - 01:47 PM

I understand what you're saying.

 

That is NOT what happens when I do drag and drop, nor when I export/import a GEDCOM file. 

 

No matter which method I use, and no matter which options I set, my great-grandfather's brother ALWAYS starts out as the first record, and when I attempt to upload such files to Ancestry or MyHeritage, both take him as the root person, and it's more than annoying to have to fix that every time I try (I STILL haven't found the way to do that with MH).

 

Perhaps I should try by just dragging ONLY the record I want as the root person, an then drag the remainder after that, and see if the first person moved can become Record 1?



#7 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 03 January 2015 - 01:52 PM

Lemme get to my computer to check.
EDIT: Yes, dragging just the start individual first gives them Record # 1. Dragging multiples makes the lowest database record number/GEDCOM-INDI numbered individual (from the import source) the new next-lowest available record number, ETC.

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#8 Patrick R

Patrick R

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 03 January 2015 - 02:04 PM

Thanks.  This is a frustrating issue, because I know there should be a simple solution.  I'd like to think I've just been making one mistake along the line to cause it, and will feel embarrassment when it is resolved, but WILL have the problem solved.  If I AM doing something wrong, I cannot see it, and I'm pretty good at finding solutions or alternatives.

 

I tried to export the file without that one person just to see, but the exported file once imported listed the former Record 2 person as Record 1.

 

While we're on the general subject of GEDCOMs, is there any way that RMG can save my settings?  I am getting tired of unchecking "LDS information" and "Multimedia links", and having to reset the "Privatize living people" each time I do this.



#9 Patrick R

Patrick R

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 03 January 2015 - 02:10 PM

EDIT: Yes, dragging just the start individual first gives them Record # 1. Dragging multiples makes the lowest database record number/GEDCOM-INDI numbered individual (from the import source) the new next-lowest available record number, ETC.

I just tried that, and that's not what I'm seeing.  It gives me the same Record # 1 person as before.

 

I noticed that Drag and Drop is just a faster way of exporting and importing the GEDCOM file, and whatever you're seeing in your file is not what I'm seeing in mine.  I let it move everyone in my tree, and I'm getting very tired of watching the same 9,000 records move each time.

 

I tried moving sections at a time, but it didn't matter.  It still is messing with me.

 

Thanks for the attempt at helping, but I'm finding something weird.  Are you using RMG7 and copying the whole tree over?



#10 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 03 January 2015 - 02:25 PM

You've lost me in here somewhere. If one creates a new empty database and imports one individual (irrespective of their original record number) via GEDCOM -or- dragN'drop ...the program *HAS* to assign that first new individual the database Record Number - 1. PERIOD.

Tools->File Options->General->Number to display after name->Record number(RIN)

Rootmagic typically saves settings *PER DATABASE* via the Tools->File Options so that one can have a database(s) separately that they might *WANT* LDS support or whatever. What you *CAN* do is create a fresh new empty database named MyDefaultBlankDatabase with the options set as you desire (back it up) and then Open it and use File->Copy to create your new database name (that is a copy of your templated settings empty new database) each time you want to start a fresh database.

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#11 Patrick R

Patrick R

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 03 January 2015 - 02:31 PM

I may have figured it out.  I copied myself into a new database.  That single record was (of course) Record 1.  Then I moved everyone over, and merged my duplicate records, making sure that the one designated Record 1 was the one that stayed.  I then did another drag and drop from that database, and it kept me as Record 1.

 

Before, I was copying over the entire database, and it kept it in its original order.  Former record # 1 is now record # 2.

 

This was a lot of work for such a simple problem.  :-)



#12 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 03 January 2015 - 02:33 PM

Glad you're closer to getting back to research ;-)

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#13 Patrick R

Patrick R

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 03 January 2015 - 02:40 PM

Rootmagic typically saves settings *PER DATABASE* via the Tools->File Options

 

This is a GEDCOM issue, and the settings in File Options do not apply to it. 

 

If you export a Gedcom file (File>Export) It will query you as to what you wish to export:  Notes, Sources, LDS information, Addresses, Multimedia links, Note formatting, and Extra details are all by default set to include, while To-Do tasks, Research logs, and Correspondence log default to excluded.  "Privatize living people" is by default set off, and it always defaults to "Full Name" and "Full date and place" should you choose to privatize.

 

I'd like to reset those to my preferences and not have to change them every time.  I will include notes (with formatting) and occasionally sourcing when I export, but since a number of my GedCom exports are to web sites, I'd prefer to leave "privatize" as a default. It shouldn't be a difficult thing to save the settings, but there is no intuitive way to do so.



#14 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 03 January 2015 - 05:22 PM

Set ALL the desired GEDCOM export settings as you wish in the skeleton template database and they should all be there when you open it, choose File->Copy and give the new cloned empty database a working name.

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#15 Patrick R

Patrick R

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 03 January 2015 - 06:41 PM

Thanks.  I will try that.



#16 Dave...

Dave...

    Member

  • Members
  • PipPip
  • 8 posts

Posted 25 October 2015 - 04:56 AM

Interesting thread, offering a helpful work-round which partly resolves the problem of changing the root person in RM (the new root person isn't recognised by Ancestry when importing a GEDCOM file).

 

However, copying 'everyone in the database' doesn't appear to copy unconnected persons, i.e., those persons who might be connected and have been added to the tree, but whose exact relationship to one or more people in the main tree hasn't been determined yet.

 

So, a specific re-indexing feature in RM to redesignate a new root person as record number 1 would be useful.

 

Dave.



#17 Patrick R

Patrick R

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 15 November 2015 - 07:06 PM

I know it's been 10 months since I was on this topic, but I need to follow up.

 

I'm still at Square One with this.  I figured out from the advice how to move the data over from one database to another and change the home person, but the results were disastrous.   Excuse me, the results were DISASTROUS.  I need to emphasize that word.

 

I lost data.  There was no rhyme or reason for it or for which data vanished, but the transfer lost data.  I didn't notice it for weeks, and I don't know how much new data I'd entered that was lost when I had to rely on a backup from before I'd made the change.  And, as a result, I'm STILL stuck with the original "home" person now.

 

 

So, back to my original question (with revision):  Is there a safe and reliable way to change the "home" record (for purposes of making a copy of the database ?



#18 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8493 posts

Posted 16 November 2015 - 11:06 AM

There really are only two options.

 

1. Go to Tools>File Options>General and select the "Root Person", then under "Start person when opening this database" use "Root person above".

 

2. Start a new blank database and only enter one person, the home/root person you want, just the name would work. Then drag n drop on top of that root person the copy from the other database. Select the options you want for who to include, but make sure you check the option "Are xxxx and xxxx the same person". This will merge the records when you do the drop.

 

You didn't mention what data you were missing?  Go to Lists>Fact Type List and make sure each fact type in checked to include when "Exporting GEDCOM files". If the option to include is uncheck then that fact will be excluded.


Renee
RootsMagic

#19 Laura

Laura

    Advanced Member

  • Members
  • PipPipPip
  • 4276 posts

Posted 16 November 2015 - 12:32 PM

I recently did an experiment on what data is transferred in drag and drop and RM specific gedcoms.  I posted the results on the Current version, Tips and Hints forum.

Data transferred in Drag and Drop or full RM Specific gedcom

http://forums.rootsm...pecific-gedcom/
 



#20 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 16 November 2015 - 12:51 PM

Obviously, the most direct way is to change ALL the information for the individual who currently occupies Record #1

Instead of a complete drag 'n drop, you could:

-drag just the two individuals you wish to swap into a fresh new temporary database, for those two records in the original database...change their names around, delete all the facts and notes, drag each of them back from the temporary database and drop them ontop of their newly swapped record number positions in the original master and answer yes they're matches (to overwrite). Link them back to the correct spouses/children and re-enter the family facts (dragging just one spouse breaks their family facts like marriage, family census, etc.

~OR~

Otherwise you have to make notes of all the fact/note/source/media particulars for each individual and then manually enter/edit/link/ETC. to accomplish the swap

Backup first of course

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N