Jump to content


Photo

Copy and Paste into Notes field loses formatting

Notes bug problem formatting

  • Please log in to reply
2 replies to this topic

#1 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3356 posts

Posted 17 December 2014 - 06:50 PM

There has been a problem with some formatting being lost by Rootsmagic when using copy and paste into the Notes field, the copy and paste of the same data works perfectly into Notepad.

 

A quick search could not find an accurate report of this problem so hopefully the video below will explain it sufficiently for development to correct it.

 

http://youtu.be/1OdOhAlbX4g

 


“Your most unhappy customers are your greatest source of learning.” -Bill Gates

 

The great Indian mathematician Aryabhat caclulated the value of pi at 3.1416, ~1500 years ago and without a computer!

 

 

User of Family Historian 6.2.7, Rootsmagic 7.5.9, Family Tree Maker 2014 & Legacy 7.5 (in order of preference)

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#2 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3442 posts

Posted 18 December 2014 - 12:19 AM

As you can see in the screenshots below, I tried to replicate your problem with my email client (Google webmail) and did not experience the symptoms you describe. If I can copy & paste w/o error, that tells me that the problem is not universal, however, I do notice that your LiveMail video example shows a "reply" screen with quoting from the original (that you are then trying to copy/paste from) and not the inbox view screen of the original "plain text" (as it's labeled on your video screen) email message itself. I'm thinking that your LiveMail client is not set up to reply to plain text messages WITH plain text messages in return ...and instead your copy operation is losing something regarding formatting (note that no characters are lost) or is picking up some hidden html or richtext formatting codes that are not transferring correctly. I suspect that if you merely opened the original email (not reply to it) and copy/paste the exact same text from the body of the original email message, that you likely could paste error-free into that RM note field. You didn't mention if you've toggled the Program Options->General->Use plain text when pasting to notes ...that may affect your outcome in a good or more bad way.

2014_12_18_004955.jpg ------ 2014_12_18_005048.jpg

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#3 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3356 posts

Posted 18 December 2014 - 04:49 AM

The problem was the same in both Outlook 2007 and 2010, I always click reply before copying to preserve the original sender detail in the note.

 

I acted on your suggestion of toggling the Program Option and the problem is now gone regardless of that setting  :rolleyes: , see below.

 

http://youtu.be/7AkIg8t2WrQ


“Your most unhappy customers are your greatest source of learning.” -Bill Gates

 

The great Indian mathematician Aryabhat caclulated the value of pi at 3.1416, ~1500 years ago and without a computer!

 

 

User of Family Historian 6.2.7, Rootsmagic 7.5.9, Family Tree Maker 2014 & Legacy 7.5 (in order of preference)

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root