Jump to content


Photo

Cannot copy and paste


  • Please log in to reply
23 replies to this topic

#21 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 6162 posts

Posted 10 February 2015 - 10:06 PM

There is something fishy with the way you describe your procedure:

 

  1) open edit person

   2) click on the fact to be changed

   3) click either Sources or Notes in the Details screen

   4) click Edit and the little pop-up appears - but there is no Edit button after you click the Notes button because the Notes Editor opens directly. And when you click on the Sources button the Citation Manager appears without having to click on some Edit button..

   5) click pop-up to open full screen - you can also drag an edge or corner of the (too small) window to resize it and that size will be remembered for the next time you open it (at least in some cases); you do not have to force it to full-screen if you don't want to.

   6) click Edit and Edit is now working!!!!! - Only the Citation Manager window has an Edit button, not the Notes window. Click Edit and the source/citation currently selected in Citation Manager is opened in the Edit Source window. The Notes Editor has a menu item called "Edit" which merely collects Cut/Copy/Paste/Undo controls under it. So what was not working and now is?

 

The image you posted was of the Edit Source window which is what you should get if you started by clicking on the Sources button in the Edit Person screen. It merely needed to be resized.


Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#22 bem

bem

    New Member

  • Members
  • Pip
  • 2 posts

Posted 07 April 2015 - 07:07 PM

I am on an iMac and cannot copy and paste into RM7. There is no anti-virus software issue.  Within RM7 I can copy and paste once in a note, but I cannot do it from any type of source document into RM7. Any suggestions?



#23 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3442 posts

Posted 08 April 2015 - 12:45 AM

Which PC emulation does that run under? Maybe another Mac user can chime in.
All I can think is to maybe try toggling

Tools->Program Options->Use plain text when pasting to notes

- If currently unchecked, place a checkmark. If already checkmarked, try removing it.

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#24 J P

J P

    Advanced Member

  • Members
  • PipPipPip
  • 298 posts

Posted 08 April 2015 - 01:10 AM

Which PC emulation does that run under? Maybe another Mac user can chime in.All I can think is to maybe try togglingTools->Program Options->Use plain text when pasting to notes- If currently unchecked, place a checkmark. If already checkmarked, try removing it.


When I changed this setting, the only effect was to affect the resulting format of the pasted text. Admittedly, I generally only copy from a Firefox (Mac) page, but I have never had any trouble with a copy and paste not producing some result, whether using Parallels, RM under CrossOver, or MacBridge. The last 2 are in active use this week at the current highest software levels.

Yes, it would be helpful to know the environment in which this problem is occurring. OSX level, RM level, environment under which RM is running, source software of the copy, etc.