Jump to content


Photo

Publish Online - table row going off page

Publish Online

  • Please log in to reply
2 replies to this topic

#1 Tina Estridge

Tina Estridge

    New Member

  • Members
  • Pip
  • 2 posts

Posted 21 October 2014 - 11:04 AM

Hi, new here. I looked for this issue but didn't find it, so I hope this helps.
 
I have used Publish Online and uploaded to my own server. I am finding that some table rows run off the page.
 
I am finding this in family group displays where only spouse rows are displayed in the table. (Only spouse is known, living person where no other data is given, etc.) If there is another row(s) with data like birth or death, all is well.
 
In reviewing the html and css, I think the problem is that the 'spouse' td has a colspan="100". If I change that to 5 it seems to work properly, since there are 6 columns in the table. I am guessing that the html is generated by javascript (which I really know nothing about).
 
I use chrome, so not sure if it's an issue in other browsers.
 


#2 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 21 October 2014 - 11:51 AM

path/to/your/publishfolder/javascript/helpers.js

$("<td colspan=100 />").append(nameLink(person,add_options)).appendTo($row);

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#3 Tina Estridge

Tina Estridge

    New Member

  • Members
  • Pip
  • 2 posts

Posted 21 October 2014 - 01:37 PM

Thank you. I changed 100 to 5 and it seems to have fixed the problem.