Jump to content


Photo

RM5 - Crossover: Attempt to Install Update Failed


  • Please log in to reply
6 replies to this topic

#1 Jillaine Smith

Jillaine Smith

    Advanced Member

  • Members
  • PipPipPip
  • 181 posts

Posted 20 December 2013 - 08:09 AM

I really want to return to RootsMagic, I do. But I sure am running into trouble... :(

I ran into a problem where in attempting to search the Source list (while trying to create a new source), RM spun and spun and spun, and neither of "cancel," "x" or "esc" worked. The only thing that worked was to force-quit CrossOver (which I only did after attempting to Force Quit RM).

So before reporting THAT error, I decided I should run the RM Update that comes up when I launch RM. (Not the upgrade to RM6, but the update to RM5.)

I attempted to do this, and the update appeared to get going. Then I got an error message. I unwisely did not copy the specific error message. But when I attempted to go back into RootsMagic, I got what appeared to be the same error message. This time, I looked at the details and copied them. I paste it below. I cannot now launch RM5 AT ALL. I am so very sad. I really want to return to RM... :-(

EurekaLog 6.0.23

Application:
------------------------------------------------------------------------
1.1 Start Date : Fri, 20 Dec 2013 09:03:01 -0500
1.2 Name/Description: RootsMagic.exe - (RootsMagic Genealogy Software)
1.3 Version Number : 5.0.4.1
1.4 Parameters :
1.5 Compilation Date: Wed, 11 Jul 2012 17:56:59 -0500
1.6 Up Time : 0 second

Exception:
----------------------------------------------------------------------
2.1 Date : Fri, 20 Dec 2013 09:03:02 -0500
2.2 Address : 005BCF89
2.3 Module Name : RootsMagic.exe - (RootsMagic Genealogy Software)
2.4 Module Version: 5.0.4.1
2.5 Type : EdxGdipException
2.6 Message : Invalid operation in GDI+ (Code: 1).
2.7 ID : BD7A
2.8 Count : 1
2.9 Status : New
2.10 Note :

User:
-------------------------------------------------------
3.1 ID : jillainesmith
3.2 Name :
3.3 Email :
3.4 Company :
3.5 Privileges: SeChangeNotifyPrivilege - ON
SeSecurityPrivilege - OFF
SeBackupPrivilege - OFF
SeRestorePrivilege - OFF
SeSystemtimePrivilege - OFF
SeShutdownPrivilege - OFF
SeRemoteShutdownPrivilege - OFF
SeTakeOwnershipPrivilege - OFF
SeDebugPrivilege - OFF
SeSystemEnvironmentPrivilege - OFF
SeSystemProfilePrivilege - OFF
SeProfileSingleProcessPrivilege - OFF
SeIncreaseBasePriorityPrivilege - OFF
SeLoadDriverPrivilege - ON
SeCreatePagefilePrivilege - OFF
SeIncreaseQuotaPrivilege - OFF
SeUndockPrivilege - OFF
SeManageVolumePrivilege - OFF
SeImpersonatePrivilege - ON
SeCreateGlobalPrivilege - ON

Active Controls:
---------------------------
4.1 Form Class : #32769
4.2 Form Text :
4.3 Control Class:
4.4 Control Text :

Computer:
-------------------------------------------------------
5.1 Name : new-host-3
5.2 Total Memory : 2048 Mb
5.3 Free Memory : 1145 Mb
5.4 Total Disk : 297.77 Gb
5.5 Free Disk : 142.67 Gb
5.6 System Up Time: 5 seconds
5.7 Processor : Intel® Pentium® 4 CPU 2.40GHz
5.8 Display Mode : 1280 x 778, 32 bit
5.9 Display DPI : 96
5.10 Video Card : X11 Windowing System (driver )
5.11 Printer : HP_DESKJET_960C (driver )

#2 Jillaine Smith

Jillaine Smith

    Advanced Member

  • Members
  • PipPipPip
  • 181 posts

Posted 20 December 2013 - 08:12 AM

(Note: I am now installing the update for CrossOver and hope that will make a difference...)

#3 Jillaine Smith

Jillaine Smith

    Advanced Member

  • Members
  • PipPipPip
  • 181 posts

Posted 20 December 2013 - 08:27 AM

It didn't make a difference; I still cannot launch RM5. I am stuck.

#4 Jillaine Smith

Jillaine Smith

    Advanced Member

  • Members
  • PipPipPip
  • 181 posts

Posted 20 December 2013 - 08:35 AM

Okay, thinking that perhaps my RM5 update failed because I wasn't running the most current version of CrossOver, I found a way to download the RM5 update and run it again without having to have RM5 running. Same error message. I think I am now forced to try RM6.

#5 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7265 posts

Posted 20 December 2013 - 09:32 AM

The instructions on this Knowledge Base article should help - http://support.roots...-with-CrossOver
Renee
RootsMagic

#6 Jillaine Smith

Jillaine Smith

    Advanced Member

  • Members
  • PipPipPip
  • 181 posts

Posted 20 December 2013 - 10:34 AM

Thanks, Renee. That will be helpful for future RM5 users who run into this problem. I bit the bullet and bought the RM6 upgrade; all seems to be working fine... so far. I *love* the source/citation templates.

#7 Robert-Leigh:Pritchett

Robert-Leigh:Pritchett

    Advanced Member

  • Members
  • PipPipPip
  • 45 posts

Posted 30 March 2014 - 12:21 PM

WineSkin Winery tends to update its engine on occasion and the error causes RM6 to not function when the updates are installed. I've had to just reinstall RM6 as new software to keep using the RM6 app.

The error that appears in WineSkin is apparently caused by a registry delink from gdiplus.dll and it seems the only way around it now is to remove the old .exe file from the winetricks subfolder for gdiplus to start fresh with a new RM6 app when going to the wineskin tricks function to add the gdi+ .dll This works with WS9Wine1.7.15 and wrapper version Wineskin-2.6.0 as of 3-30-2014.

It also appears that WineSkin does use the Crossover function wthout being subscribed to Crossover directly, however the instructions provided by Crossover do not work with Wineskin. Using Wineskin Winery obviates the necessity to keep paying the annual subscription to Crossover - which is nearly twice the price of RM6!

Drew Withers still has the best instructions on how to install Wineskin Winery and RM6 at http://blog.drewwith...n-mac-os-x.html

I also add the IE8 browser when using wineskin tricks.