Jump to content


Photo

Changing tags in Categories/People/Places


  • Please log in to reply
10 replies to this topic

#1 baluo

baluo

    Member

  • Members
  • PipPip
  • 29 posts

Posted 05 November 2013 - 04:53 PM

I have made the following observation re the behaviour of tags in these three fields in the Add New Story window:


If I have to change any of them
* I find the sorting changed and the ticked tags are at the top. This is irritating while normally they are organised by alphabet, although on the other hand it is helpful because it shows the activated tags right upfront ...

* However, *un-ticking* an activated tag has in several cases now caused the the next unticked tag (i.e. following those on top) to be activated, sometimes losing all the tags activated before, or outher such erratic behaviour.

* Adding a *new* entry (Person/Category ...) regularly un-ticks the *last* entry in the list, as far as I can see ...

I hope this makes sense.

#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 6957 posts

Posted 06 November 2013 - 11:41 AM

I have made the following observation re the behaviour of tags in these three fields in the Add New Story window:


If I have to change any of them
* I find the sorting changed and the ticked tags are at the top. This is irritating while normally they are organised by alphabet, although on the other hand it is helpful because it shows the activated tags right upfront ...

I am confirming seeing this. It is noted in our tracking system.

* However, *un-ticking* an activated tag has in several cases now caused the the next unticked tag (i.e. following those on top) to be activated, sometimes losing all the tags activated before, or outher such erratic behaviour.

* Adding a *new* entry (Person/Category ...) regularly un-ticks the *last* entry in the list, as far as I can see ...


I am not seeing this behavior. Maybe I'm not testing this right. Give me step by steps instructions.
Renee
RootsMagic

#3 baluo

baluo

    Member

  • Members
  • PipPip
  • 29 posts

Posted 06 November 2013 - 04:21 PM

Give me step by steps instructions.



Enter a few names, for instance in the People menu (Stories > People). Close menu and open "Add New Story". In the "People" field, activate a few names. Close this menu. Open again and select "Add New". Enter a new name. If you watch carefully for the second or so, and then in the "People" entry field, the *last* of the names previously activated in the listing and having been moved to the top is being de-selected.

A few more tests show that this happens when creating three or more "People" entries in the "Add new" menu.

Also, I just discovered - or rather, saw again - that a new entry created within the "Add New" menu can *replace* another one or even a whole set (in my test case: those created before within the "Add New" menu).


As tagging is one of the most important features in using PH, this makes it extremely unreliable.

#4 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 6957 posts

Posted 12 November 2013 - 11:30 AM

I am still unable to recreate this. I see the list change, but its only going into alphabetically order. What I don't see is the lose of anyone in the list. No one become unchecked and no one else is added automatically.

What version of Personal Historian do you have? Help>About Personal Historian version 2.0.2.3 is the latest.

Try going to File>Properties>Check/Repair File.. and run that to rule out having a problem with your database.
Renee
RootsMagic

#5 baluo

baluo

    Member

  • Members
  • PipPip
  • 29 posts

Posted 25 November 2013 - 06:44 AM

I am still unable to recreate this. I see the list change, but its only going into alphabetically order. What I don't see is the lose of anyone in the list. No one become unchecked and no one else is added automatically.

What version of Personal Historian do you have? Help>About Personal Historian version 2.0.2.3 is the latest.

Try going to File>Properties>Check/Repair File.. and run that to rule out having a problem with your database.


I do use the newest PH version downloaded from your server a few weeks ago. The Check/Repair function told me that the file was ok.

The effect happens when I "Add New" a category, person or place, not if I just tick or untick an entry. It happens in all my browsers and for all three modes.

#6 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 6957 posts

Posted 25 November 2013 - 10:04 AM

Not sure what you mean by happening in all my browsers and all three modes? PH doesn't access an internet browser.

It's probably best to open a support ticket and send a backup of your PH database. That way we can test what is happening.

http://support.roots...us_requests/new
Renee
RootsMagic

#7 baluo

baluo

    Member

  • Members
  • PipPip
  • 29 posts

Posted 02 December 2013 - 05:40 AM

Sorry, I don't know what happened to my response a few days ago:


> browsers
You are right, Rene, of course, I meant to refer to all three modes only.

> ticket
Yes, I have opened a ticket.

#8 baluo

baluo

    Member

  • Members
  • PipPip
  • 29 posts

Posted 04 July 2014 - 09:38 PM

Hi Renee,

 

has there been a solution of this problem?

 

If not, and if I haven't provided you with a clear problem description, here another attempt:

 

- Any given story with a number of entries e.g. in Categories

- open this story, go to Categories, "Add New" category

- new category will be added to the list of ticked categories for this story

- HOWEVER, the first few (so far up to three) already existing Cat entries are being replaced by the first few (up to three) Cat entries of the entire Category listing, while the new entry remains ticked.

- I then have to untick those self-ticked entries and re-select those Cat entries I had previously selected.

 

For the way I use PH this is an important problem, and I would be great if an update could change it.



#9 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 6957 posts

Posted 09 July 2014 - 11:44 AM

Confirming issue is noted in our tracking system.


Renee
RootsMagic

#10 genealogy4primm@earthlink.

genealogy4primm@earthlink.

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 15 May 2017 - 08:24 PM

I was tinkering today in PH and found a similar anomaly as described by the OP regarding Places in PH. 

PH ver 2.1.1.1 (12 Nov 2014)

When I am working in a Story and select Places field to add a Place, the Story's Places field accommodates the additional Places as long as they are already in the Place List.

However, once I attempt to "Add new" via the "Add Place" dialogue screen, the new Place Name is put in the Story Place field, but also the first three or more and other Places in the Place List are exchanged, or added to, the existing Places already entered in the Story's Place field. That is; my previous Place entries in the Story's Place field are shown, but also three additional Places that I did not select are also displayed in the Place field. If I attempt to correct these in the Story's Place field, the Story Place field drops down to just displaying the last "Add New" "Add Place" entry.

For example:
I populate the Place field in Stories to have these existing Place List entries:

Places: Switzerland; America; France; United States

Then I decide to add Holland (Netherlands), a place not already in the Place List, as an "Add New" Add Place" and then the Place field in Stories then has this:

Places:  Adairsville, Bartow County, Georgia, United States; Afton, Oklahoma Territory, United States; Aiken, Aiken County, South Carolina, United States; Holland

As can be seen by this list of places, three of the original Place List entries are now gone, and the United States is duplicated. I also note that the United States, nor are the previous selected Places, are no longer checked in the Place List, but the undesired Places and Holland are now checked.

When I attempt to correct this by removing check marks for the undesired places that I never selected, Adairsville, Bartow, Afton & Aiken, now in the Story's Place field, I get this:

Places: Holland


Thus adding a "New Place" to the Story simply does not work as expected if there are existing Places already listed in the Place field.


A workaround appears to be that one should not "Add New" Add Place" from within a Story, unless it is only one place and the first Place entered. The better procedure would be to select Manage Places world/globe icon (or Stories > Places) to add any New Places to the Place List before starting a Story.

Granted most of the time one would have a 'complete' Place List already imported from their genealogy file and would never likely come across such an anomaly. I was constructing a time line based on the Gregorian and Julian Calendars, and the dates affected during those respective changes in different countries for a reference, or Historical context Story, thus I did not have all of the Places already in my imported Place List.



 



#11 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 6957 posts

Posted 19 May 2017 - 10:16 AM

Confirming I could reproduce this issue and added it to the development list.


Renee
RootsMagic