Jump to content


Photo

Primary fact not displaying in Family view

Facts Family view Primary

  • Please log in to reply
1 reply to this topic

#1 mglafond

mglafond

    Member

  • Members
  • PipPip
  • 10 posts

Posted 11 September 2013 - 11:43 AM

Maybe I'm doing something wrong, and if so, I hope someone can point me in the proper direction.

I have an individual in my RM 6 database for whom I have two birth facts. It turns out, the original date I had is off by two days from this newer information, but rather than discard the original date (since I have no primary source for either date), I entered a second fact, and marked it as the primary fact. When I look at the individual as the Father in the Family View, the date of the original birth fact is displaying, rather than the "primary" fact that I more recently entered. The help file indicates that the primary facts will be used on printed reports, etc., but shouldn't it also be used for on-screen display? Is this a bug, or a stupid user error? ;)

#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8474 posts

Posted 11 September 2013 - 01:32 PM

First check to make sure that the other fact isn't also marked primary. You want only one marked primary. If the indexes and displays don't update then go to File>Database Tools and run all options in consecutive order. The Rebuild Indexes will fix this but its good to run all tools periodically on your database.
Renee
RootsMagic





Also tagged with one or more of these keywords: Facts, Family view, Primary