Jump to content


Photo

Images in Posts


  • Please log in to reply
31 replies to this topic

#21 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3368 posts

Posted 17 April 2013 - 04:00 PM

You have to check the share link that Dropbox provides. If it is https (Hypertext Transfer Protocol Secure), it looks like the forum may not accept a link with that Secure protocol identifier. If you use the Dropbox option to shorten the name, it changes it to http and it does seem to work, like this example of an image in my Dropbox folder.

I hadn't noticed that problem before, but it is good to know. If you use the Preview Post option when writing a message with a link, you can check the link in that post preview.

Should be able to just omit the 's' on the end of that protocol (just use http: instead of https:) and include the full path like this:
http://dl.dropboxusercontent.com/u/3797379/DavisResearch.jpg
into the URL block presented when one clicks the Image icon to insert an image inline with other reply content.Posted Image

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#22 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5744 posts

Posted 17 April 2013 - 06:23 PM

TomH -

We're talking about two different things - images linked with the Link icon (using Dropbox in my example, in reply to someone having a problem with Dropbox links) or using the Image icon and entering the Properties which is apparently what you are talking about. I don't know anything about the Image insertion or whether it is enabled in this board.

Virginia

the topic is about "Images in posts", not plain text hyperlinks. The OP was talking about having a problem with image insertion (linked image) even with an URL from Dropbox. I think this issue is resolved by kbens0n's and my posts: don't use https or short URLs, use http and URL with full filename including extension.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> Rmtrix_tiny.png app, a bundle of RootsMagic utilities.


#23 Paul Harris

Paul Harris

    Advanced Member

  • Members
  • PipPipPip
  • 152 posts

Posted 17 April 2013 - 08:57 PM

You need to paste the full URL with the file extension .png, .jpg not the cryptic short URL with no extension into the Image tag in order to link to an external image. Without the extension you get the misleading error message. I have never been able to upload/attach an image directly to the forum.

Like this:

http://s6.postimg.org/hsxptzr8t/SQLite_Tools_For_Roots_Magic_banner_40.png
Not this:
http://postimg.org/image/hsxptzr8t/
To get this: Posted Image

If you toggle the editing mode (top left button) to see the tags, the result is this:
[img]http://s6.postimg.org/hsxptzr8t/SQLite_Tools_For_Roots_Magic_banner_40.png[/img]

There are two linked images in my signature.


Tom,

Thanks for your input. This is the exact text I am pasting into the URL field of the Image Tool in the Post Editor:

https://www.dropbox....o8/Places-1.jpg

I believe it is the FULL URL, not shortened. If I paste it into the control in this Post I get:

Posted Image

#24 Ludlow Bay

Ludlow Bay

    Advanced Member

  • Members
  • PipPipPip
  • 861 posts

Posted 17 April 2013 - 09:12 PM

Tom,

Thanks for your input. This is the exact text I am pasting into the URL field of the Image Tool in the Post Editor:

https://www.dropbox....o8/Places-1.jpg

I believe it is the FULL URL, not shortened. If I paste it into the control in this Post I get:

Posted Image

Doesn't work for me, either:

Posted Image - using https://


Posted Image - using http://

#25 Paul Harris

Paul Harris

    Advanced Member

  • Members
  • PipPipPip
  • 152 posts

Posted 17 April 2013 - 09:15 PM

Virginia,

Your example has revealed my problem:

http://dl.dropboxusercontent.com/u/3797379/DavisResearch.jpg

Works for you, but when I go to my web based dropbox folder and ask for the share link I get:

https://www.dropbox.com/s/9neue0e6illbo8/Places-1.jpg

which does not work in the Image Tool. Neither does removing the 's', as you suggested. However, if I remove the 's' AND change 'www.drobox.com' to 'dl.dropboxusercontent.com' I get:

Posted Image


My problem is I do not seem to know how to recover the correct URL from dropbox, or do I always need to manually change the domain?

Thanks, Virginia,

Paul

#26 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5744 posts

Posted 17 April 2013 - 09:51 PM

Dropbox has changed since this was first posted. Linking images is now a little more difficult.

 

This image is straight from DropBox:

RMtrixDatabaseProperties-screen.PNG?raw=

 

The above image is in my Dropbox Public folder but it could be in any folder. Even files in the Public folder are not public by default it seems. Each can be unshared, shared privately or publicly and there are various settings for what those with the link can do. On the Dropbox website, I hovered the mouse over the file's row or clicked on the name to access a Share button. Clicking on "Share" opens a message form that will have either a "Copy link" hyperlink or "Create a link". If not "Copy..." then click "Create..." to result in "Copy..." and click it to copy the link to the clipboard. That gave the URL

https://www.dropbox.com/s/s4w6dipxddxn2ku/RMtrixDatabaseProperties-screen.PNG?dl=0

But that doesn't work. You need to replace "dl=0" with "raw=1".

 

So https is just fine. The key is the full path being obtained from the right source.

If, instead, I left-click on the filename in DropBox to view the image and then right-click the image to get the image URL, I get

https://photos-6.dropbox.com/t/2/AAB_8XT7BRdaNIvFnbZTQAafO7-W1na3XxTCKSMLGW0pGw/12/4222803/png/32x32/1/_/1/2/RMtrixDatabaseProperties-screen.PNG/EKTWlQMYnA8gBygH/zyHumqfuFFzzzYnADzdxQRrXxzndh4CDlXKskUtjBrk?preserve_transparency=1&size=32x32&size_mode=5

which does not work.


Edited by TomH, 22 April 2018 - 12:50 PM.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> Rmtrix_tiny.png app, a bundle of RootsMagic utilities.


#27 Paul Harris

Paul Harris

    Advanced Member

  • Members
  • PipPipPip
  • 152 posts

Posted 17 April 2013 - 10:04 PM

Tom,

That is what I was missing. I wasn't grabbing the Public Link. Learned more than I wanted to this evening, but I am glad this issue is finally resolved for me.

Thanks to Tom and Virginia, ever so much.

Paul

#28 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5744 posts

Posted 19 April 2018 - 05:19 AM

Having forced the RootsMagic Forums users to post images to external hosts, the awful risk of the URL breaking has happened. Now there are hundreds of topics with broken links to images stored on postimage.org. The host and images still exist but the direct link to the file, as required by the Forums software, has changed. All or most of mine were via s6.postimg.org. A Google of the term "postimg.org" site:forums.RootsMagic.com returns many broken images.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> Rmtrix_tiny.png app, a bundle of RootsMagic utilities.


#29 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5744 posts

Posted 19 April 2018 - 06:34 AM

Discovered why the links to postimg.org are broken. An undated bulletin on the postimages.org/contact page says:

postimg.ORG domain is locked by Registry, no prior notice.

 

While we hope to resolve the issue, we chose postimg.CC as our new home.
Please update codes embedded in your websites.

 

Simply replacing postimg.org with postimg.cc in the URL restores the link to the image file. I guess the question remains whether to await a (hopefully) timely restoration of the postimg.org domain to postimages.org or to plough ahead finding and editing one's old posts.

 

Or could the admin do a global search and replace?


Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> Rmtrix_tiny.png app, a bundle of RootsMagic utilities.


#30 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5744 posts

Posted 21 April 2018 - 08:33 AM

Or could the admin do a global search and replace?

Using the search term (with quotes) "postimg.org" returns 149 topics in which the most likely match is the URL to 1 or more external image. To restore the usefulness of these discussions, the broken image links need to be fixed. Each one of the original authors of a message with a broken postimg.org image link could edit their messages to change the domain to postimg.cc but that is unlikely to happen comprehensively. If there is any search & replace feature that the forum administrators could apply, please do so!

 

I, alone, authored about 50 posts with images from postimg.org.


Edited by TomH, 21 April 2018 - 08:42 AM.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> Rmtrix_tiny.png app, a bundle of RootsMagic utilities.


#31 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7708 posts

Posted 23 April 2018 - 07:17 AM

I'm having them check to see if that is possible.


Renee
RootsMagic

#32 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5744 posts

Posted 26 April 2018 - 03:26 PM

I had a PM from the RootsMagician that he could find no search & replace tool for the Forums posts with which a global replacement of "postimg.org" by "postimg.cc" could be carried out. That means the restoration of images either awaits the recovery of the postimg.org domain by postimages.org or the editing by each author of his/her own posts containing such image links. Pity... 


Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> Rmtrix_tiny.png app, a bundle of RootsMagic utilities.