Jump to content


Photo

To Dos


  • Please log in to reply
28 replies to this topic

#21 Guest_Lynne_*

Guest_Lynne_*
  • Guests

Posted 11 August 2004 - 08:22 PM

I just received my copy of RM v2.0 and was anxious to install it. Was I disconcerted to find that my TODO's lost their owner in one out of my three databases! I have literally hundreds of to do tasks which now belong to General. There are a few which belong to a person, but not many. I'm assuming the upgrade caused it but I don't know for sure. It has been a while since I created a list of to do's from this database. If anyone has figured anything out, I would be grateful.
The only thing I did between the upgrade and finding this problem, was to color code people. However, I did that on all three databases, and still only one has been affected.
I do have a prior backup of this database on another computer. Any way to bring in just the to do list from this? I have no idea how many or what changes I've made since that backup was made.

#22 Patricia

Patricia

    Advanced Member

  • Members
  • PipPipPip
  • 145 posts

Posted 11 August 2004 - 09:12 PM

Were these Family ToDos or Individual ToDos or both. I know there is a problem with the Family ToDos, and ToDos that have not been linked to a person. But have not known of any problems with the Individual ToDos. Please check this carefully and report back with what type you have lost.

#23 Mike MacKean

Mike MacKean

    Member

  • Members
  • PipPip
  • 17 posts

Posted 12 August 2004 - 06:18 AM

I'm still having problems with this area too - my only gripe with RM.

I asked for the technical team to help, but all they could say was that 'they coudn't replicate the problem'.

I've tried several methods to pinpoint exactly where the problem is. It's worth noting that I have only ever added To Do's to an individual, and never a family.

What I have found is that the To Do's are NOT lost from any NEW individuals, entered into RM2 since migrating from Family Origins to RM1.04. However, older individuals, default to the General To Do list, and lose any details entered in any other field on that screen. Luckily I printed off a few To Do List reports before I lost the data! Can anyone else replicate my findings?

I have tried re-indexing too, but I haven't found it made any difference.

#24 lynne

lynne

    New Member

  • Members
  • Pip
  • 1 posts

Posted 12 August 2004 - 08:59 PM

[Were these Family ToDos or Individual ToDos or both. I know there is a problem with the Family ToDos, and ToDos that have not been linked to a person. But have not known of any problems with the Individual ToDos. Please check this carefully and report back with what type you have lost.]

I had both individual (birth records, obit) and family to do's (census) which are now General. I have only 17 to do's assigned to individuals now, out of several hundred, none left assigned to families.
For the most part, the to do's I have left assigned are for higher numbered individuals, but there is one exception of a lower numbered individual. Also, of the higher numbered individuals, there are many, many people in between those fewwhich no longer have any to do's

#25 traveler856

traveler856

    Member

  • Members
  • PipPip
  • 8 posts

Posted 26 August 2004 - 10:52 AM

Re losing ToDo's:
I lost the entries from the individuals. I haven't been able to see a pattern, except that the 'to do's' disappear. I also found that some reappeared as general 'to do's', but not all and I can't see a pattern.

I haven't done any fancy things like import, export, copy, etc. I bought the original Roots Magic in person at the NGS convention, moved from Familiy Tree Maker and didn't have a problem the first couple of times I was collecting repository lists of 'to do's'. I even updated the tasks as completed and saw that they didn't appear in the 'to do' list the next time I ran it. Then, I was planning a return visit to a repository and tried to print a list, only to find there was nothing there.

I haven't been working with my genealogy much this summer, so I don't have any new information.

Traveler856

#26 Germer

Germer

    Member

  • Members
  • PipPip
  • 8 posts

Posted 31 October 2004 - 07:50 AM

Yes, this happened to me too.

This must have happened when I converted from FO to RM ... as all the dates listed with blank names are prior to converting. All new ToDo items are fine. Those converted from FO are missing the indivuals name. I guess I will have to go back to FO and list the ToDos and then update RM.

#27 Guest_branagak_*

Guest_branagak_*
  • Guests

Posted 17 March 2005 - 02:32 PM

[For those who don't like the suspense of troubleshooting, jump to the bottom of this email and read what caused my corrupt to-dos -- where individual todos were converted to general todos.]

Today I was struck by the todo bug as discussed in length in both the mailing list and the message board. After searching both locations for information, I could not find a cause, workaround, fix or resolution for this problem. So, I thought I would articulate how I use RootsMagic and see if my troubleshooting steps offer any insight to this significant problem for someone who has 926 open todos.

I use RM on a Dell OptiPlex WXP PC.
I have added over 100 personal todo's in the past week.
I have never added a family or general to do.
I backup my database each time I close RM, overwriting the oldest of the 6 backup files on the PC.
I compress my database every couple months.
I have been using RM like this for several years.

Here is what I did today:

I edited some notes, added a few individual tasks and deleted a couple people.

I ran a todo list report to find all the open tasks for a specific repository.
There were 319 todos, but nearly all of them had no "Who" assigned.
This had not occurred when I ran a similar report yesterday.

I ran another report for all open todos that were "linked to people" REPORTS>LISTS>TO DO LIST>PERSON, and selected everyone in the database.
The report brought up 51 tasks, all created in the past two days (March 16 and 17)!
No task created prior to March 16 was linked to an individual.

I ran the same two reports for completed tasks.
One report for all completed tasks for a specific repository, and there were 131 items, and nearly all of them had no "Who" assigned.
One report for all completed todos that were "linked to people," and there were only 4 - those that were completed yesterday and today!

I compressed my database.
I ran the same open and completed todo reports.
I got the same results.

I restored the backup from March 16, 2005.
I ran a report for all open todos, and they all looked fine.
I ran a report for all General todos, and there were none, which was a correct result, since I have never added a General todo.

Ah ha! Something happened to my database today!
I normally do not delete people from the database, so I deleted the same people again.
I created a todo report, and it was corrupted.

I restored the good database again.
I checked the people I deleted this morning. One of them had a personal do to assigned to it.
I deleted a different person who had a personal do to assigned to him. It corrupted the todos again.

So, before you delete someone from the database, REMOVE ANY ASSOCIATED TODOS FROM THE PERSON!

Kim Branagan

PS - Thank goodness for backups!!

#28 RootsMagician

RootsMagician

    Administrator

  • Admin
  • PipPipPip
  • 826 posts

Posted 17 March 2005 - 04:15 PM

QUOTE (branagak @ Mar 17 2005, 01:32 PM)
So, before you delete someone from the database, REMOVE ANY ASSOCIATED TODOS FROM THE PERSON!

Or... make sure you have the latest version (2.03) which fixes this problem.

http://www.rootsmagic.com/updates.htm

RootsMagician

#29 miguelk

miguelk

    Advanced Member

  • Members
  • PipPipPip
  • 76 posts

Posted 13 July 2005 - 02:43 PM

Roots 2.03 DOESN'T completely fix the problem of To-Dos that wander from "individual" to "general".

I discovered this in a "duplicate merge" process. During the process, I added a large number of To-Do tasks, always as an individual To-Do. I don't recall if I would add the To-Do before merging two individuals, or after. However, once I started to work on the To-Do list (by using the List function), I found a significant percentage that had become "General" To-Dos. And the ONLY activity that I had performed was "merge". No Gedcom export or Import, no backup, nothing that has been reported as the trigger for a "wandering" To-Do. Why are these To-Dos becoming "general" To-Dos?