Jump to content


Photo

RootsMagic To Go issue


  • Please log in to reply
5 replies to this topic

#1 Rick H

Rick H

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts

Posted 01 July 2011 - 08:39 PM

WXP Pro SP3 on AMD Processor 1GB Ram
Two physical disks with three partitions on each.
Disk 1 C:, N:, O:
Disk 2 D:, E:, F:
M: is a CD

My RM data (and My Documents) is on D:

I Plug in thumb drive G:
Start RMTG and the display shows:
the default device is D:
Load software to D:
Copy database to D:

I Pull down the device to G: and the display shows:
Load software to G:
Copy database to C: <<<<<< C?

Did the reinstall of the software to G: and the database still pointed at C:
I tried other devices and the install and database showed correctly.

I deleted (via Windoze Explorer) the two .RMGC files on G:\Rootsmagic-4\Data and then the RMTG process worked fine.

After this I restarted RMTG and the same (failing) situation showed up.

This has been working for years on this system, it may have changed at V4.1.1.4 or .5 (I think .5 is most likely)
I don't believe anything changed (at least by my hand) on this system other than M$ updates and AV data updates.

\s\Rick

#2 Rick H

Rick H

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts

Posted 01 July 2011 - 08:41 PM

Subject should have been "New Release will NOT load my flash drive"

#3 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7271 posts

Posted 06 July 2011 - 09:55 AM

We haven't made any changes to RootsMagic To-Go in over a year. I did test this and found the same differences in drive letter verse where it will write to on one of my external drives (Z). My desktop uses this drive to read and write to RootsMagic so it would be copying my files on (Z) to my RootsMagic To-Go on Z.

When I clicked on the option to "Transfer data to and from C" it actually showed the correct drive letter Z in the transfer file window. If for some reason you need to change the drive letter click on the button "Change folders".
Renee
RootsMagic

#4 Rick H

Rick H

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts

Posted 06 July 2011 - 01:11 PM

Well I have just had to build a completely new system as the old one was dying. This new one is still two disks, three partitions each. The CPU is an Intel P4, 3.0Ghz and 1.5GB ram.

I can confirm that your second paragraph is true here too. Says it is updating C but once you get into the file selection page it says it is updating [now] H:. Strange, I am nearly 100% sure this is reasonably new behavior as I have been using this thumb drive for several years and never noticed this behavior before.

I also discovered that even though it says C from the selection page, as long as I had H: selected in the previous page I did not need to use 'change folders' to get H updated. Once completed and back to the original RM To Go page the Data Transfer panel shows H?

So between what you have discovered and the workaround I discovered (delete the database via Windoze Explorer first) there is no pressure for an fix, however an answer to the underlying cause would allow me to sleep at night (~"P

thanks for the update Renee
\s\Rick


We haven't made any changes to RootsMagic To-Go in over a year. I did test this and found the same differences in drive letter verse where it will write to on one of my external drives (Z). My desktop uses this drive to read and write to RootsMagic so it would be copying my files on (Z) to my RootsMagic To-Go on Z.

When I clicked on the option to "Transfer data to and from C" it actually showed the correct drive letter Z in the transfer file window. If for some reason you need to change the drive letter click on the button "Change folders".



#5 Rick H

Rick H

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts

Posted 09 July 2011 - 11:23 AM

Now this is weird. The same system I referenced here, today, showed the proper drive in both the Program and Data Transfers panel?

I had just cloned in my RM3 databases to the Desktop's RM4. Then used To-Go to move the two databases to the flash drive and it all displayed and worked as expected.

I guess I will have to record event sequences more carefully to see what might be causing this anomaly.

\s\Rick


Well I have just had to build a completely new system as the old one was dying. This new one is still two disks, three partitions each. The CPU is an Intel P4, 3.0Ghz and 1.5GB ram.

I can confirm that your second paragraph is true here too. Says it is updating C but once you get into the file selection page it says it is updating [now] H:. Strange, I am nearly 100% sure this is reasonably new behavior as I have been using this thumb drive for several years and never noticed this behavior before.

I also discovered that even though it says C from the selection page, as long as I had H: selected in the previous page I did not need to use 'change folders' to get H updated. Once completed and back to the original RM To Go page the Data Transfer panel shows H?

So between what you have discovered and the workaround I discovered (delete the database via Windoze Explorer first) there is no pressure for an fix, however an answer to the underlying cause would allow me to sleep at night (~"P

thanks for the update Renee
\s\Rick



#6 Rick H

Rick H

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts

Posted 12 November 2012 - 08:13 PM

recently it clicked - only been a year ...

The proper display of the device being updated happens when there is no conflict between the Desk-side and Flash databases. If there is conflict then the device label is not shown correctly but RMTG does update the proper area.

Since I only move data from Desk-side to Flash I don't know if the update in the reverse direction is working properly.

\s\Rick
PS I have dropped RM4 in favor of RM5 about 6 months ago and this seems to have remained consistent through that change.